Tricefy USA -- Uplink 4.4+ unable to connect

Incident Report for Tricefy

Resolved

No further issues have been observed.
Posted Feb 09, 2026 - 17:14 UTC

Monitoring

The rotation issue has been resolved, and we are monitoring for any further impact.
Posted Feb 09, 2026 - 17:00 UTC

Identified

The issue has been identified and we are implementing a fix.
Posted Feb 09, 2026 - 16:16 UTC

Investigating

A routine certificate rotation issue is temporarily causing the Uplink connection to fail to Receiving, for the USA environment only. Uplink versions before 4.4 are not affected by this issue.
Those experiencing this problem will see "Client TLS negotiation failure" in the Uplink logs.
Posted Feb 09, 2026 - 16:15 UTC
This incident affected: us.tricefy.com (Receiving USA).