Tricefy is experiencing occasional SMS delivery issues within some countries

Incident Report for Tricefy

Monitoring

A fix has been implemented which should allow most SMS messages to be successfully delivered moving forward.

All original patient share link SMS messages in "undelivered" status since Tuesday May 19th have also been resent.
Posted May 21, 2026 - 19:55 UTC

Update

The Trice team is continuing to investigate the issue and working with the SMS provider to resolve as soon as possible.

In the United States, those using Verizon as their wireless carrier are the most impacted; and least likely to receive a Tricefy patient share link via SMS (text message).

For any patient that urgently needs the images shared, you can send them to an email address from the Tricefy web portal. When this issue is resolved, the "undelivered" patient share link messages will be resent.

We will continue to provide more updates as they come. Thank you!
Posted May 20, 2026 - 23:00 UTC

Investigating

We are investigating some intermittent failures with sending SMS messages, primarily for patient share links. The SMS provider Tricefy uses is currently having partial connectivity issues.
Posted May 19, 2026 - 17:52 UTC
This incident affects: tricefy4.com (Tricefy Web) and us.tricefy.com (Tricefy USA Web).