New Version Released (4.4.74)

Incident Report for Tricefy

Resolved

We are pleased to announce Tricefy 4.4.74!

What's new:

- Added support for components and subcomponents in HL7 message segments
- Fixed page layout issues when resizing the window
Posted Jun 01, 2026 - 16:11 UTC
This incident affected: tricefy4.com (Tricefy Web) and us.tricefy.com (Tricefy USA Web).