New Version Released (4.4.53)

Incident Report for Tricefy

Resolved

We are pleased to announce Tricefy 4.4.53!

What's new:

- Fixed an issue where the active annotation tool in the preliminary report viewer could not be changed
- Improved support for two Modality Worklist fields for some machines
- Minor technology updates
Posted Mar 03, 2026 - 22:49 UTC
This incident affected: tricefy4.com (Tricefy Web) and us.tricefy.com (Tricefy USA Web).